It not a joke!!! It is the truth!!!

Giving people what they want: violence and sloppy eating

Previous Entry Share Next Entry
Ah, that's why that Firefox add-on was valid up to version 6
mini me + poo
lovingboth
I saw in MintUpdate that there was a Firefox update and thought that the version number (5.0) was a mistake. But no, they've released Firefox 5.

Adding new features: nice.

Moving the whole 4.x release to 'unsupported' status three months after its launch: not nice.

This entry was originally posted at http://lovingboth.dreamwidth.org/431808.html, because despite having a permanent account, I have had enough of LJ's current owners trying to be evil. Please comment there using OpenID - have and if you have an LJ account, you can use it for your OpenID account. Or just join Dreamwidth! It only took a couple of minutes to copy all my entries here to there.

  • 1
Cor. Was there something Very Wrong in v4 to spark this perhaps?

No, they've just moved to much shorter times between releases. They're expecting to be at version 7 by the end of the year, despite 6 and 7 being 'smaller incremental updates'.

I had thought the days of 'Oh, the competition are on Product v10, let's skip a few version points to catch up' were over.

For people needing stability (see the share of the commercial market still using IE6), it's a nightmare. You either need to update every three months with all the retesting and deployment issues that involves, or end up with insecure browsers because no-one's fixing the known bugs.

Ahhh. And Bah. And ta. :)

  • 1
?

Log in